The February meeting has been rescheduled to February 26. Woody's SIG meeting for February has been cancelled.

Disable Windows 10 Firewall

User avatar
TomTom
Site Admin
Posts: 394
Joined: Thu Feb 19, 2015 11:18 pm
Contact:

Disable Windows 10 Firewall

Postby TomTom » Fri Aug 05, 2016 1:18 pm

I have had recurring problems with the Windows 10 Firewall constantly disabling or deleting my firewall rules, especially after Windows updates. See my previous article, Windows 10 Firewall Broke AGAIN! for a refresher. I finally decided to install Comodo Free Firewall on both my main desktop and my main laptop, and will probably do so on my other Windows 10 computers as well.

After setting up Comodo Free Firewall however, I ran into a new problem. I turned off the Windows Firewall with the command "C:\Windows\explorer.exe shell:::{4026492F-2F69-46B8-B9BF-5654FC07E423", then "Turn Windows Firewall on or off"), as you should not have 2 firewalls running. I found that the Windows Firewall kept turning itself back on, conflicting with the Comodo Free Firewall, and preventing other computers from access (as it also kept disabling the rules for printer and file sharing). Each time I turned WF off again, I could access the computer for a little while until it turned on again, even after a reboot!

So is there a way to prevent Windows Firewall from starting/running, if you are using an alternative firewall such as Comodo Free Firewall?

According to this Tom's Hardware post, you can disable the Windows Firewall from the Services window. To do so:
  • In the Cortana search bar, type SERVICES.MSC.
  • Click the Services option that appears in the suggestion list.
  • From the opened Services window, from the right pane, double-click the Windows Firewall service.
  • On the Windows Firewall Properties box, ensure that you are on the General tab.
  • Click the Stop button from under the Service status label and click Apply. (Accept any prompt or confirmation that/if appears to stop any dependencies.)
  • After this, choose Disabled from the Startup type drop-down list and click Apply again.
  • Click OK and close all the opened boxes.
  • Restart the computer and see if this keeps Windows Firewall from turning on automatically. Note that this did work for both of my Windows 10 computers, and I can finally communicate between them without hassle.
If this doesn't work, this Technet post offers a few other suggestions, or do a search for "windows firewall keeps starting".
A mind needs books as a sword needs a whetstone, if it is to keep its edge.
- Tyrion Lannister

Return to “Windows 10”

Who is online

Users browsing this forum: No registered users and 1 guest